FrontstageLaunchBackstageItemProps Interface
Properties for a FrontstageLaunchBackstageItem component
Extends
Properties
Name | Type | Description | |
---|---|---|---|
frontstageId | string | id of the frontstage |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
description | string | StringGetter | DescriptionProps | if set, it is used to explicitly set the description shown by a component. |
descriptionKey | undefined | string | DescriptionProps | if set, it is used to define a key that is used to look up a localized string. |
iconSpec | undefined | IconSpec | IconProps | CSS class name or SvgSprite for icon |
isActive | undefined | false | true | BackstageItemProps | if set, component will be shown with as the active item - defaults to false |
isEnabled | undefined | false | true | BackstageItemProps | if set, component will be enabled - defaults to true |
label | string | StringGetter | LabelProps | if set, it is used to explicitly set the label shown by a component. |
labelKey | undefined | string | LabelProps | if set, it is used to define a key that is used to look up a localized string. |
stateFunc | undefined | (state: Readonly<BackstageItemState>) => BackstageItemState | BackstageItemProps | optional function to set state of backstage item |
stateSyncIds | undefined | string[] | BackstageItemProps | optional SyncUi event ids that will trigger the state function to run. |
tooltip | string | StringGetter | TooltipProps | used to explicitly set the tooltip shown by a component. |
tooltipKey | undefined | string | TooltipProps | if set, it is used to define a key that is used to look up a localized string. |
Defined in
Last Updated: 13 June, 2024