WeightPropertyEditor Class
Beta
WeightPropertyEditor returns React component WeightEditor to select a color value.
Extends
Implements
Inherited methods
Name | Inherited from | Description |
---|---|---|
applyEditorParams(_property: PropertyDescription, _record: PropertyRecord): void | PropertyEditorBase | |
commitValue(newValue: PropertyValue, record: PropertyRecord): Promise<AsyncValueProcessingResult> | PropertyEditorBase | |
validateValue(newValue: PropertyValue, record: PropertyRecord): Promise<AsyncValueProcessingResult> | PropertyEditorBase |
Properties
Name | Type | Description | |
---|---|---|---|
reactElement Accessor ReadOnly | React.ReactNode |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
customDataController | DataController | undefined | PropertyEditorBase |
Defined in
Last Updated: 13 June, 2024