PropertyEditorProps Interface
Beta
Properties for a property editor component
Extends
Properties
Name | Type | Description | |
---|---|---|---|
onBlur | undefined | (event: FocusEvent) => void | Handler for blur | |
onCancel | undefined | () => void | Handler for cancel | |
onCommit | undefined | (args: PropertyUpdatedArgs) => void | Handler for commit | |
propertyRecord | undefined | PropertyRecord | The property being updated. | |
setFocus | undefined | false | true | Indicates whether the Property Editor should set focus |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
className | undefined | string | ClassNameProps | Custom CSS class name |
style | undefined | React.CSSProperties | CommonProps | Custom CSS style properties |
Defined in
Last Updated: 13 June, 2024