SelectedNodeInstancesSpecification Interface
Creates content for current selection.
Note: No data is returned for selected custom nodes.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
acceptableClassNames | undefined | string[] | Filter selected nodes by specified class names. | |
acceptablePolymorphically | undefined | boolean | Should SelectedNodeInstancesSpecification.acceptableClassNames property be checked polymorphically. | |
acceptableSchemaName | undefined | string | Filter selected nodes by specified schema name. | |
onlyIfNotHandled | undefined | boolean | Identifies whether we should ignore this specification if there is already an existing specification | |
specType | SelectedNodeInstances | Used for serializing to JSON. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
calculatedProperties | undefined | CalculatedPropertiesSpecification[] | ContentModifiersList | Specifications for including calculated properties |
priority | undefined | number | ContentSpecificationBase | Defines the order in which specifications are evaluated and executed. |
propertiesDisplay | undefined | PropertiesDisplaySpecification[] | ContentModifiersList | Specifications for customizing property display by hiding / showing them |
propertyCategories | undefined | PropertyCategorySpecification[] | ContentModifiersList | Specifications for custom categories. |
propertyEditors | undefined | PropertyEditorsSpecification[] | ContentModifiersList | Specifications for assigning property editors |
propertyOverrides | undefined | PropertySpecification[] | ContentModifiersList | Specifications for various property overrides. |
relatedInstances | undefined | RelatedInstanceSpecification[] | ContentSpecificationBase | Specifications for joining related instances |
relatedProperties | undefined | RelatedPropertiesSpecification[] | ContentModifiersList | Specifications for including properties of related instances |
showImages | undefined | boolean | ContentSpecificationBase | Should each content record be assigned an image id |
Defined in
Last Updated: 13 June, 2024