InstanceNodesOfSpecificClassesSpecification Interface
Creates nodes for all instances of specified ECClasses.
Extends
Properties
Name | Type | Description | |
---|---|---|---|
arePolymorphic | undefined | boolean | Should all InstanceNodesOfSpecificClassesSpecification.classes be handled polymorphically. | |
classes | MultiSchemaClassesSpecification | MultiSchemaClassesSpecification[] | Specifications of ECClasses whose instances should be returned. | |
instanceFilter | undefined | string | Condition for filtering instances of defined classes. | |
specType | InstanceNodesOfSpecificClasses | Used for serializing to JSON. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
doNotSort | undefined | boolean | ChildNodeSpecificationBase | Set this flag to true to suppress default sorting of ECInstances returned by this specification. |
groupByClass | undefined | boolean | DefaultGroupingPropertiesContainer | Group instances by ECClass. |
groupByLabel | undefined | boolean | DefaultGroupingPropertiesContainer | Group instances by label. |
hasChildren | "Always" = undefined | "Never" = undefined | "Unknown" = undefined | ChildNodeSpecificationBase | This tells the rules engine that nodes produced using this |
hideExpression | undefined | string | ChildNodeSpecificationBase | An ECExpression which |
hideIfNoChildren | undefined | boolean | ChildNodeSpecificationBase | Hide nodes if they don't have children. |
hideNodesInHierarchy | undefined | boolean | ChildNodeSpecificationBase | Hide nodes provided by this specification and directly show nodes of its children. |
nestedRules | undefined | ChildNodeRule[] | ChildNodeSpecificationBase | Nested rule specifications. |
priority | undefined | number | ChildNodeSpecificationBase | Defines the order in which specifications are evaluated and executed. |
relatedInstances | undefined | RelatedInstanceSpecification[] | ChildNodeSpecificationBase | Specifications of related instances that can be used in content creation. |
Defined in
Last Updated: 13 June, 2024