RectangleTool Class
Beta
Tool for placing Markup Rectangles
Extends
Methods
Name | Description | |
---|---|---|
constructor(_cornerRadius?: number): RectangleTool | ||
createMarkup(svgMarkup: G, ev: BeButtonEvent, isDynamics: boolean): void Protected | ||
showPrompt(): void Protected |
Inherited methods
Name | Inherited from | Description |
---|---|---|
applyToolSettingPropertyChange(_updatedValue: ToolSettingsPropertySyncItem): boolean | InteractiveTool | Used to receive property changes from UI. |
autoLockTarget(): void | PrimitiveTool | Called on data button down event to lock the tool to its current target model. |
beginDynamics(): void | InteractiveTool | Call to initialize dynamics mode. |
changeLocateState(enableLocate: boolean, enableSnap?: false | true, cursor?: string, coordLockOvr?: CoordinateLockOverrides): void | InteractiveTool | Helper method to keep the view cursor, display of locate circle, and coordinate lock overrides consistent with isLocateEnabled and isSnapEnabled. |
clearDynamicsMarkup(_isDynamics: boolean): void Protected | RedlineTool | |
decorate(_context: DecorateContext): void | InteractiveTool | Called to allow an active tool to display non-element decorations in overlay mode. |
decorateSuspended(_context: DecorateContext): void | InteractiveTool | Called to allow a suspended tool to display non-element decorations in overlay mode. |
endDynamics(): void | InteractiveTool | Call to terminate dynamics mode. |
exitTool(): void | PrimitiveTool | |
filterHit(_hit: HitDetail, _out?: LocateResponse): Promise<LocateFilterStatus> | InteractiveTool | Invoked to allow tools to filter which elements can be located. |
getCurrentButtonEvent(ev: BeButtonEvent): void | InteractiveTool | Fill the supplied button event from the current cursor location. |
getDecorationGeometry(_hit: HitDetail): GeometryStreamProps | undefined | InteractiveTool | Called to allow snapping to pickable decoration geometry. |
getPrompt(): string | PrimitiveTool | Returns the prompt based on the tool's current state. |
getToolTip(_hit: HitDetail): Promise<HTMLElement | string> | InteractiveTool | Invoked before the locate tooltip is displayed to retrieve the information about the located element. |
initLocateElements(enableLocate?: false | true, enableSnap?: false | true, cursor?: string, coordLockOvr?: CoordinateLockOverrides): void | InteractiveTool | Helper method for tools that need to locate existing elements. |
isCompatibleViewport(vp: Viewport | undefined, isSelectedViewChange: boolean): boolean | MarkupTool | |
isComplete(_ev: BeButtonEvent): boolean Protected | RedlineTool | |
isValidLocation(ev: BeButtonEvent, isButtonEvent: boolean): boolean | PrimitiveTool | Checks that the adjusted point from the supplied button event is within the project extents for spatial views. |
onAdded(el: MarkupElement): void Protected | RedlineTool | |
onCleanup(): void | RedlineTool | |
onDataButtonDown(ev: BeButtonEvent): Promise<EventHandled> | RedlineTool | |
onDataButtonUp(_ev: BeButtonEvent): Promise<EventHandled> | InteractiveTool | Invoked when the data button is released. |
onDynamicFrame(_ev: BeButtonEvent, _context: DynamicsContext): void | InteractiveTool | Called to allow Tool to display dynamic elements. |
onInstall(): boolean | MarkupTool | |
onKeyTransition(_wentDown: boolean, _keyEvent: KeyboardEvent): Promise<EventHandled> | InteractiveTool | Called when any key is pressed or released. |
onMiddleButtonDown(_ev: BeButtonEvent): Promise<EventHandled> | InteractiveTool | Invoked when the middle mouse button is pressed. |
onMiddleButtonUp(_ev: BeButtonEvent): Promise<EventHandled> | InteractiveTool | Invoked when the middle mouse button is released. |
onModifierKeyTransition(_wentDown: boolean, _modifier: BeModifierKeys, _event: KeyboardEvent): Promise<EventHandled> | InteractiveTool | Called when Control, Shift, or Alt modifier keys are pressed or released. |
onMouseEndDrag(ev: BeButtonEvent): Promise<EventHandled> | InteractiveTool | Invoked when the button is released after onMouseStartDrag. |
onMouseMotion(ev: BeButtonEvent): Promise<void> | RedlineTool | |
onMouseStartDrag(_ev: BeButtonEvent): Promise<EventHandled> | InteractiveTool | Invoked when the cursor begins moving while a button is depressed. |
onMouseWheel(_ev: BeWheelEvent): Promise<EventHandled> | InteractiveTool | Invoked when the mouse wheel moves. |
onPostInstall(): void | MarkupTool | |
onRedoPreviousStep(): Promise<boolean> | PrimitiveTool | Called to reinstate to a previous tool state (ex. |
onReinitialize(): void | RedlineTool | |
onResetButtonDown(_ev: BeButtonEvent): Promise<EventHandled> | InteractiveTool | Invoked when the reset button is pressed. |
onResetButtonUp(_ev: BeButtonEvent): Promise<EventHandled> | RedlineTool | |
onRestartTool(): void | RedlineTool | |
onSelectedViewportChanged(_previous: Viewport | undefined, current: Viewport | undefined): void | PrimitiveTool | Called when active view changes. |
onSuspend(): void | InteractiveTool | Notification of a ViewTool or InputCollector starting and this tool is being suspended. |
onTouchCancel(ev: BeTouchEvent): Promise<void> | MarkupTool | |
onTouchComplete(ev: BeTouchEvent): Promise<void> | MarkupTool | |
onTouchEnd(_ev: BeTouchEvent): Promise<void> | InteractiveTool | Called when user removes a touch point by lifting a finger or stylus from the surface. |
onTouchMove(ev: BeTouchEvent): Promise<void> | MarkupTool | |
onTouchMoveStart(ev: BeTouchEvent, startEv: BeTouchEvent): Promise<EventHandled> | MarkupTool | |
onTouchStart(_ev: BeTouchEvent): Promise<void> | InteractiveTool | Called when user adds a touch point by placing a finger or stylus on the surface. |
onTouchTap(_ev: BeTouchEvent): Promise<EventHandled> | InteractiveTool | Called when touch point(s) are added and removed from a surface within a small time window without any touch point moving. |
onUndoPreviousStep(): Promise<boolean> | RedlineTool | |
onUnsuspend(): void | MarkupTool | |
outputMarkupPrompt(msg: string): void Protected | MarkupTool | |
parseAndRun(..._args: string[]): boolean | Tool | Run this instance of a tool using a series of string arguments. |
pickElement(pt: XAndY): MarkupElement | undefined | MarkupTool | Find the topmost MarkupElement at the specified point in the markup view. |
provideToolAssistance(mainInstrKey: string, singlePoint: boolean = false): void Protected | RedlineTool | |
redoPreviousStep(): Promise<boolean> | MarkupTool | |
requireWriteableTarget(): boolean | MarkupTool | |
run(..._args: any[]): boolean | PrimitiveTool | Establish this tool as the active PrimitiveTool. |
saveChanges(): Promise<void> | PrimitiveTool | Tools need to call SaveChanges to commit any elements they have added/changes they have made. |
setCurrentStyle(element: MarkupElement, canBeFilled: boolean): void Protected | MarkupTool | |
setCurrentTextStyle(element: MarkupElement): void Protected | MarkupTool | |
setupAndPromptForNextAction(): void Protected | RedlineTool | |
supplyToolSettingsProperties(): ToolSettingsPropertyRecord[] | undefined | InteractiveTool | Used to supply list of properties that can be used to generate ToolSettings. |
syncToolSettingsProperties(syncData: ToolSettingsPropertySyncItem[]): void | InteractiveTool | Called by tool to synchronize the UI with property changes made by tool. |
testDecorationHit(_id: string): boolean | InteractiveTool | Called to support operations on pickable decorations, like snapping. |
undoPreviousStep(): Promise<boolean> | MarkupTool | |
register(namespace?: I18NNamespace, i18n?: I18N): void Static | Tool | Register this Tool class with the ToolRegistry. |
Properties
Name | Type | Description | |
---|---|---|---|
_cornerRadius ProtectedConstructorProperty | undefined | number | ||
iconSpec Static | string | ||
toolId Static | string |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
_minPoints Protected | number | RedlineTool | |
_nRequiredPoints Protected | number | RedlineTool | |
_points Protected | Point3d[] | RedlineTool | |
description Accessor ReadOnly | string | Tool | Get the localized description string from this Tool's class |
description Accessor StaticReadOnly | string | Tool | Get the localized description for this Tool class. This returns the value of "tools." + this.toolId + ".description" from its registered Namespace (e.g. "en/MyApp.json"). If that key is not in the localization namespace, flyover is returned. |
englishKeyin Accessor StaticReadOnly | string | Tool | Get the English keyin string for this Tool class. This returns the value of "tools." + this.toolId + ".keyin" from its registered Namespace (e.g. "en/MyApp.json"). |
flyover Accessor ReadOnly | string | Tool | Get the localized flyover string from this Tool's class |
flyover Accessor StaticReadOnly | string | Tool | Get the localized flyover for this Tool class. This returns the value of "tools." + this.toolId + ".flyover" from its registered Namespace (e.g. "en/MyApp.json"). If that key is not in the localization namespace, keyin is returned. |
hidden Static | boolean | Tool | If true, this Tool will not appear in the list from getToolList. |
i18n Static | I18N | Tool | The internationalization services instance used to translate strings from the namespace. |
iconSpec Accessor ReadOnly | string | Tool | Get the iconSpec from this Tool's class. |
iModel Accessor ReadOnly | IModelConnection | PrimitiveTool | Get the iModel the tool is operating against. |
isDynamicsStarted Accessor ReadOnly | boolean | InteractiveTool | Call to find out if dynamics are currently active. |
keyin Accessor ReadOnly | string | Tool | Get the localized keyin string from this Tool's class |
keyin Accessor StaticReadOnly | string | Tool | Get the localized keyin string for this Tool class. This returns the value of "tools." + this.toolId + ".keyin" from its registered Namespace (e.g. "en/MyApp.json"). |
markup | Markup | MarkupTool | |
maxArgs Accessor StaticReadOnly | number | undefined | Tool | The maximum number of arguments allowed by parseAndRun, or undefined if there is no maximum. If subclasses override parseAndRun, they should also override this method to indicate the maximum number of arguments their implementation expects. |
minArgs Accessor StaticReadOnly | number | Tool | The minimum number of arguments allowed by parseAndRun. If subclasses override parseAndRun, they should also override this method to indicate the minimum number of arguments their implementation expects. UI controls can use this information to ensure the tool has enough information to execute. |
namespace Static | I18NNamespace | Tool | The I18NNamespace that provides localized strings for this Tool. |
receivedDownEvent | boolean | InteractiveTool | Used to avoid sending tools up events for which they did not receive the down event. |
targetIsLocked | boolean | PrimitiveTool | |
targetModelId | undefined | string | PrimitiveTool | |
targetView | undefined | Viewport | PrimitiveTool | |
toolId Accessor ReadOnly | string | Tool | Get the toolId string for this Tool class. This string is used to identify the Tool in the ToolRegistry and is used to localize the keyin, description, etc. from the current locale. |
toolKey Static | string | MarkupTool |
Defined in
- core/markup/src/RedlineTool.ts Line 124
Last Updated: 13 June, 2024