DisplayStyle2dState Class
A display style that can be applied to 2d views.
Extends
Implements
Methods
Name | Description | |
---|---|---|
constructor(props: DisplayStyleProps, iModel: IModelConnection): DisplayStyle2dState |
Inherited methods
Name | Inherited from | Description |
---|---|---|
changeBackgroundMapProps(props: BackgroundMapProps): void | DisplayStyleState | Modify a subset of the background map display settings. |
clone(iModel?: IModelConnection): this | EntityState | Make an independent copy of this EntityState |
dropSubCategoryOverride(id: Id64String): void | DisplayStyleState | Remove any SubCategoryOverride applied to a SubCategoryAppearance by this style. |
equalState(other: DisplayStyleState): boolean | DisplayStyleState | Performs logical comparison against another display style. |
equals(other: this): boolean | EntityState | Return true if this EntityState is equal to another one. |
getSubCategoryOverride(id: Id64String): SubCategoryOverride | undefined | DisplayStyleState | Obtain the overrides applied to a SubCategoryAppearance by this style. |
is3d(): this is DisplayStyle3dState | DisplayStyleState | Returns true if this is a 3d display style. |
overrideSubCategory(id: Id64String, ovr: SubCategoryOverride): void | DisplayStyleState | Customize the way geometry belonging to a SubCategory is drawn by this display style. |
setBackgroundMap(mapProps: BackgroundMapProps): void | DisplayStyleState | Modify the background map display settings. |
Properties
Name | Type | Description | |
---|---|---|---|
settings Accessor ReadOnly | DisplayStyleSettings |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
analysisStyle Accessor | AnalysisStyle | undefined | DisplayStyleState | Settings controlling display of analytical models. |
backgroundColor Accessor | ColorDef | DisplayStyleState | The background color for this DisplayStyle |
backgroundMapSettings Accessor | BackgroundMapSettings | DisplayStyleState | The settings controlling how a background map is displayed within a view. |
classFullName Accessor StaticReadOnly | string | EntityState | Get full BIS class name of this Entity in the form "SchemaName:ClassName". |
classFullName | string | EntityState | The full class name in the form "schema:class". |
className Accessor ReadOnly | string | EntityState | The name of the BIS class associated with this class. |
code | Code | ElementState | The Code for this element |
federationGuid | undefined | GuidString | ElementState | A FederationGuid assigned to this element by some other federated database |
hasSubCategoryOverride Accessor ReadOnly | boolean | DisplayStyleState | Returns true if an [[SubCategoryOverride]s are defined by this style. |
id | Id64String | EntityState | The Id of this Entity. |
iModel | IModelConnection | EntityState | The iModel from which this Entity was loaded |
jsonProperties | [key: string]: any | EntityState | Optional json properties of this Entity. |
model | Id64String | ElementState | The ModelId of the Model containing this element |
monochromeColor Accessor | ColorDef | DisplayStyleState | The color used to draw geometry in monochrome mode. |
name Accessor ReadOnly | string | DisplayStyleState | The name of this DisplayStyle |
parent | undefined | RelatedElement | ElementState | The parent Element of this, or undefined if no parent. |
schemaName Accessor StaticReadOnly | string | EntityState | The name of the BIS schema for this class. |
userLabel | undefined | string | ElementState | A user-assigned label for this element. |
viewFlags Accessor | ViewFlags | DisplayStyleState | The ViewFlags associated with this style. |
Defined in
Last Updated: 13 June, 2024