RenderSystem Class
A RenderSystem provides access to resources used by the internal WebGL-based rendering system. An application rarely interacts directly with the RenderSystem; instead it interacts with types like Viewport which coordinate with the RenderSystem on the application's behalf. A RenderSystem provides access to resources used by the internal WebGL-based rendering system. An application rarely interacts directly with the RenderSystem; instead it interacts with types like Viewport which coordinate with the RenderSystem on the application's behalf.
Extended by
- MockRender.System
Implements
Methods
Name | Description | |
---|---|---|
createBranch(branch: GraphicBranch, transform: Transform): RenderGraphic | Create a RenderGraphic consisting of a list of Graphics, with optional transform and symbology overrides applied to the list | |
createGraphicBuilder(placement: Transform, type: GraphicType, viewport: Viewport, pickableId?: Id64String): GraphicBuilder Abstract | Creates a GraphicBuilder for creating a RenderGraphic. | |
createGraphicList(primitives: RenderGraphic[]): RenderGraphic Abstract | Create a RenderGraphic consisting of a list of Graphics to be drawn together. | |
createGraphicOwner(ownedGraphic: RenderGraphic): RenderGraphicOwner | Create a graphic that assumes ownership of another graphic. | |
createMaterial(_params: Params, _imodel: IModelConnection): RenderMaterial | undefined | Create a RenderMaterial from parameters | |
createSkyBox(_params: SkyGradient.CreateParams): RenderGraphic | undefined | Create a Graphic for a SkyBox which encompasses the entire scene, rotating with the camera. | |
createTextureFromImage(_image: HTMLImageElement, _hasAlpha: boolean, _imodel: IModelConnection | undefined, _params: Params): RenderTexture | undefined | Create a new texture from an HTML image. | |
createTextureFromImageBuffer(_image: ImageBuffer, _imodel: IModelConnection, _params: Params): RenderTexture | undefined | Create a new texture from an ImageBuffer. | |
createTextureFromImageSource(source: ImageSource, imodel: IModelConnection | undefined, params: Params): Promise<RenderTexture | undefined> | Create a new texture from an ImageSource. | |
findMaterial(_key: string, _imodel: IModelConnection): RenderMaterial | undefined | Find a previously-created RenderMaterial by its ID. | |
findTexture(_key: string, _imodel: IModelConnection): RenderTexture | undefined | Find a previously-created RenderTexture by its ID. | |
getGradientTexture(_symb: Symb, _imodel: IModelConnection): RenderTexture | undefined | Obtain a texture created from a gradient. | Beta |
Properties
Name | Type | Description | |
---|---|---|---|
debugControl Accessor ReadOnly | RenderSystemDebugControl | undefined | Obtain an object that can be used to control various debugging features. | Beta |
Defined in
Last Updated: 13 June, 2024