ToolSettingsValue Class
Deprecated Move ToolSettingsValue to bentley/ui-abstract beginning in iModel.js 2.0.
Beta
Primitive ToolSettings Value.
Implements
Methods
Name | Description | |
---|---|---|
constructor(value?: number | string | boolean | Date, displayValue?: string): ToolSettingsValue | ||
clone(): ToolSettingsValue | ||
update(newValue: ToolSettingsValue): boolean |
Properties
Name | Type | Description | |
---|---|---|---|
displayValue | undefined | string | ||
hasDisplayValue Accessor ReadOnly | boolean | ||
isNullValue Accessor ReadOnly | boolean | ||
value | number | string | boolean | Date | ||
valueFormat | Primitive |
Defined in
Last Updated: 13 June, 2024