FontMap Class
A FontMap holds the table of known fonts available in an iModel. A font is referenced by an "id" that is local to the iModel. This table maps those local ids to a FontProps.
Methods
Name | Description | |
---|---|---|
constructor(props?: FontMapProps): FontMap | ||
addFonts(fonts: FontProps[]): void | ||
getFont(arg: string | number): FontProps | undefined | look up a font by name or number and return its FontProps | |
toJSON(): FontMapProps |
Properties
Name | Type | Description | |
---|---|---|---|
fonts | Map<number, FontProps> |
Defined in
- core/common/src/Fonts.ts Line 28
Last Updated: 15 June, 2021