MobileRpcConfiguration Class
Beta
Holds configuration for the RpcInterfaces used by the application.
Extends
Inherited methods
Name | Inherited from | Description |
---|---|---|
assign<T extends RpcInterface>(definition: RpcInterfaceDefinition<T extends RpcInterface>, supplier: RpcConfigurationSupplier): void Static | RpcConfiguration | Sets the configuration supplier for an RPC interface class. |
initializeInterfaces(configuration: RpcConfiguration): void Static | RpcConfiguration | Initializes the RPC interfaces managed by the configuration. |
obtain<T extends RpcConfiguration>(configurationConstructor: { constructor: undefined }): T extends RpcConfiguration Static | RpcConfiguration | Obtains the instance of an RPC configuration class. |
Properties
Name | Type | Description | |
---|---|---|---|
args Accessor StaticReadOnly | any | Read the mobile rpc args | |
isIOSFrontend Accessor StaticReadOnly | any | Check if running backend running on wkwebview on ios | |
isMobileBackend Accessor StaticReadOnly | boolean | Check if running backend running on mobile | |
isMobileFrontend Accessor StaticReadOnly | boolean | Check if running backend running on mobile | |
platform Accessor StaticReadOnly | RpcMobilePlatform | Return type of mobile platform using browser userAgent | |
protocol Abstract | MobileRpcProtocol |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
developmentMode Static | boolean | RpcConfiguration | Whether development mode is enabled. |
interfaces Abstract | () => RpcInterfaceDefinition[] | RpcConfiguration | The RPC interfaces managed by the configuration. |
pendingOperationRetryInterval | number | RpcConfiguration | The target interval (in milliseconds) between connection attempts for pending RPC operation requests. |
strictMode Static | boolean | RpcConfiguration | Whether strict mode is enabled. |
throwOnTokenMismatch Static | boolean | RpcConfiguration | Whether to throw an error when the IModelToken in the operation parameter list differs from the token in the URL. |
Object Literals
Name | Description |
---|---|
requestContext Static | Enables passing of application-specific context with each RPC request. |
Defined in
Last Updated: 13 June, 2024