TypeDefinition Class
A RelatedElement relationship that describes the TypeDefinitionElement of an element.
Extends
Implements
Methods
Name | Description | |
---|---|---|
constructor(props: RelatedElementProps): TypeDefinition |
Inherited methods
Name | Inherited from | Description |
---|---|---|
fromJSON(json?: RelatedElementProps): RelatedElement | undefined Static | RelatedElement | |
idFromJson(json: any): Id64String Static | RelatedElement | Accept the value of a navigation property that might be in the shortened format of just an id or might be in the full RelatedElement format. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
id | Id64String | RelatedElement | The Id of the element to which this element is related. |
none Static | RelatedElement | RelatedElement | Used to null out an existing navigation relationship. |
relClassName | undefined | string | RelatedElement | The full className of the relationship class. |
Defined in
- core/common/src/ElementProps.ts Line 74
Last Updated: 13 June, 2024