GeometricElementProps Interface
Properties of a GeometricElement
Extends
Properties
Name | Type | Description | |
---|---|---|---|
category | Id64String | The id of the category for this geometric element. | |
geom | undefined | GeometryStreamProps |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
classFullName | string | EntityProps | The full name of the ECClass for this entity, in the form "Schema:ClassName" |
code | CodeProps | ElementProps | The Code for this element |
federationGuid | undefined | GuidString | ElementProps | A FederationGuid assigned to this element by some other federated database |
id | undefined | Id64String | EntityProps | The Id of the entity. |
jsonProperties | undefined | any | ElementProps | Optional json properties of this element. |
model | Id64String | ElementProps | The Id of the Model containing this element |
parent | undefined | RelatedElementProps | ElementProps | The Parent of this element, if defined. |
userLabel | undefined | string | ElementProps | A user-assigned label for this element. |
Defined in
- core/common/src/ElementProps.ts Line 80
Last Updated: 13 June, 2024