OidcBackendClient Class
Beta
Utility to generate OIDC/OAuth tokens for backend applications
Extends
Extended by
Methods
Inherited methods
Name |
Inherited from |
Description |
delete(requestContext: AuthorizedClientRequestContext, relativeUrlPath: string): Promise<void> Protected |
Client |
used by clients to send delete requests |
getUrl(requestContext: ClientRequestContext): Promise<string> |
Client |
Gets the URL of the service. |
getUrlSearchKey(): string Protected |
OidcClient |
Gets name/key to query the service URLs from the URL Discovery Service ("Buddi") |
setupOptionDefaults(options: RequestOptions): Promise<void> Protected |
Client |
Augments request options with defaults returned by the DefaultRequestOptionsProvider. |
Properties
Inherited properties
Name |
Type |
Inherited from |
Description |
_url Protected |
undefined | string |
Client |
|
searchKey Static |
string |
OidcClient |
|
Defined in
Last Updated:
13 June, 2024