polygonXYAreaDifferenceLoopsToPolyface MethodStatic
return a polyface containing the area difference of two XY regions.
- Within each region, in and out is determined by parity rules.
- Any face that is an odd number of crossings from the far outside is IN
- Any face that is an even number of crossings from the far outside is OUT
polygonXYAreaDifferenceLoopsToPolyface(loopsA: MultiLineStringDataVariant, loopsB: MultiLineStringDataVariant, triangulate: boolean = false): Polyface | undefined
Parameter | Type | Description |
---|---|---|
loopsA | MultiLineStringDataVariant | first set of loops |
loopsB | MultiLineStringDataVariant | second set of loops |
triangulate | boolean |
Returns - Polyface | undefined
Defined in
- core/geometry/src/curve/RegionOps.ts Line 408
Last Updated: 13 June, 2024