collectCurvePrimitives Method
Return an array containing only the curve primitives.
collectCurvePrimitives(collectorArray?: CurvePrimitive[], smallestPossiblePrimitives: boolean = false): CurvePrimitive[]
Parameter | Type | Description |
---|---|---|
collectorArray | CurvePrimitive[] | optional array to receive primitives. If present, new primitives are ADDED (without clearing the array.) |
smallestPossiblePrimitives | boolean | if false, CurvePrimitiveWithDistanceIndex returns only itself. If true, it recurses to its (otherwise hidden) children. |
Returns - CurvePrimitive[]
Defined in
Last Updated: 13 June, 2024