perpendicularPartOfVectorToTarget Method
Construct a vector from ray.origin
to target point.
- return the part of the vector that is perpendicular to
ray.direction
. - i.e. return the shortest vector from the ray to the point.
perpendicularPartOfVectorToTarget(targetPoint: XYAndZ, result?: Vector3d): Vector3d
Parameter | Type | Description |
---|---|---|
targetPoint | XYAndZ | |
result | Vector3d |
Returns - Vector3d
Defined in
Last Updated: 13 June, 2024