intersectRay Method
Compute intersections with a ray.
- Return the number of intersections
- Fill any combinations of arrays of
- rayFractions = fractions along the ray
- xyz = xyz intersection coordinates points in space
- thetaPhiRadians = sphere longitude and latitude in radians.
- For each optional array, caller must of course initialize an array (usually empty)
- return 0 if ray length is too small.
intersectRay(ray: Ray3d, rayFractions: number[] | undefined, xyz: Point3d[] | undefined, thetaPhiRadians: Point2d[] | undefined): number
Parameter | Type | Description |
---|---|---|
ray | Ray3d | |
rayFractions | number[] | undefined | |
xyz | Point3d[] | undefined | |
thetaPhiRadians | Point2d[] | undefined |
Returns - number
Defined in
Last Updated: 13 June, 2024