create MethodStatic
Create a bspline with given knots.
- Two count conditions are recognized:
** If poleArray.length + order == knotArray.length, the first and last are assumed to be the extraneous knots of classic clamping. ** If poleArray.length + order == knotArray.length + 2, the knots are in modern form.
create(poleArray: Float64Array | Point3d[], knotArray: Float64Array | number[], order: number): BSplineCurve3d | undefined
Parameter | Type | Description |
---|---|---|
poleArray | Float64Array | Point3d[] | |
knotArray | Float64Array | number[] | |
order | number |
Returns - BSplineCurve3d | undefined
Defined in
Last Updated: 13 June, 2024