Id64.iterate Function
Execute a function on each Id64String of an Id64Arg, optionally terminating before iteration completes.
iterate(arg: Id64Arg, callback: (id: Id64String) => boolean): boolean
Parameter | Type | Description |
---|---|---|
arg | Id64Arg | The Id(s) to iterate. |
callback | (id: Id64String) => boolean | The function to invoke on each Id. The function returns false to terminate iteration, or true to continue iteration. |
Returns - boolean
True if all Ids were iterated, or false if iteration was terminated due to the callback returning false.
Defined in
- core/bentley/src/Id.ts Line 347
Last Updated: 13 June, 2024