IPresentationLabelsProvider Interface
Interface for presentation rules-driven labels provider.
Implemented by
Methods
Name | Description | |
---|---|---|
getLabel(key: InstanceKey): Promise<string> | Get label for instance identified with the given key. | |
getLabels(keys: InstanceKey[]): Promise<string[]> | Get labels for instances identified with the given keys. |
Properties
Name | Type | Description | |
---|---|---|---|
imodel Readonly | IModelConnection | IModelConnection used by this data provider |
Defined in
Last Updated: 30 November, 2023