Content
Types related to presentation content.
Classes
Name | Description | |
---|---|---|
Content | A data structure that contains the Descriptor and a list of Item | |
Descriptor | Data structure that describes content: fields, sorting, filtering, format, etc. | |
Field | Describes a single content field. | |
Item | A data structure that represents a single content record. | |
NestedContentField | Describes a content field that contains Nested content. | |
PropertiesField | Describes a content field that's based on one or more similar |
Enumerations
Name | Description | |
---|---|---|
ContentFlags | Flags that control content format. | |
DefaultContentDisplayTypes | Displayed content types. | |
FieldDescriptorType | Types of different field descriptors. | |
PropertyValueFormat | Format of the property value. | |
SortDirection | Data sorting direction |
Global Functions
Name | Description | |
---|---|---|
addFieldHierarchy | Adds a field hierarchy into root field hierarchies list. | |
combineFieldNames | Combines given field names in a way that allows them to be parsed back into a list of individual names using the parseCombinedFieldNames function. | |
createFieldHierarchies | Parses a list of Field objects into a list of FieldHierarchy. | |
parseCombinedFieldNames | Parses given combined field names string, constructed using combineFieldNames, into a list of individual field names. | |
traverseContent | An utility to traverse content using provided visitor. | |
traverseContentItem | An utility for calling traverseContent when there's only one content item. | |
traverseFieldHierarchy | An utility for traversing field hierarchy. |
Interfaces
Name | Description | |
---|---|---|
ArrayTypeDescription | Type description for array properties. | |
BaseFieldJSON | Data structure for a Field serialized to JSON. | |
BaseTypeDescription | Data structure for base content field type description. | |
CategoryDescription | A data structure that describes a Field category. | |
CategoryDescriptionJSON | Serialized CategoryDescription JSON representation. | |
ContentJSON | Serialized Content JSON representation. | |
DescriptorJSON | Serialized Descriptor JSON representation. | |
DescriptorOverrides | Descriptor overrides that can be used to customize content | |
DescriptorSource | Descriptor properties | |
DisplayValueGroup | A group of raw values and their common display value. | |
DisplayValueGroupJSON | JSON representation of DisplayValueGroup. | Deprecated |
DisplayValuesArray | An array of display values | |
DisplayValuesArrayJSON | JSON representation of DisplayValuesArray | Deprecated |
DisplayValuesMap | A map of display values | |
DisplayValuesMapJSON | JSON representation of DisplayValuesMap | Deprecated |
EditorDescription | A data structure which describes property editor used | |
FieldDescriptorBase | Base for a field descriptor | |
FieldHierarchy | A data structure to define a hierarchy of Field objects. | |
IContentVisitor | An interface for a visitor that can be passed to the traverseContent function | |
ItemJSON | Serialized Item JSON representation. | |
NamedFieldDescriptor | Field descriptor that identifies a content field by its unique name. | |
NestedContentFieldJSON | Data structure for a NestedContentField serialized to JSON. | |
NestedContentValue | Data structure that describes nested content value. | |
NestedContentValueJSON | JSON representation of NestedContentValue | Deprecated |
PrimitiveTypeDescription | Type description for primitive properties. | |
ProcessFieldHierarchiesProps | Props for the IContentVisitor.processFieldHierarchies call. | |
ProcessMergedValueProps | Props for the IContentVisitor.processMergedValue call. | |
ProcessPrimitiveValueProps | Props for the IContentVisitor.processPrimitiveValue call. | |
PropertiesFieldDescriptor | Field descriptor that identifies a properties field using a list of | |
PropertiesFieldJSON | Data structure for a PropertiesField serialized to JSON. | |
Property | Data structure that describes a single ECProperty that's | |
PropertyAccessor | Data structure that describes one step of property | |
PropertyJSON | JSON representation of Property | |
RendererDescription | Describes property renderer used for a content Field. | |
SelectClassInfo | Data structure that describes an ECClass in content Descriptor. | |
SelectClassInfoJSON | Serialized SelectClassInfo JSON representation | |
SelectionInfo | Data structure that contains selection information. | |
StartArrayProps | Props for the IContentVisitor.startArray call. | |
StartCategoryProps | Props for the IContentVisitor.startCategory call. | |
StartContentProps | Props for the IContentVisitor.startContent call. | |
StartFieldProps | Props for the IContentVisitor.startField call. | |
StartItemProps | Props for the IContentVisitor.startItem call. | |
StartStructProps | Props for the IContentVisitor.startStruct call. | |
StructFieldMemberDescription | A data structure that describes a struct member. | |
StructTypeDescription | Type description for struct properties. | |
ValuesArray | An array of raw values | |
ValuesArrayJSON | JSON representation of ValuesArray | Deprecated |
ValuesMap | A map of raw values | |
ValuesMapJSON | JSON representation of ValuesMap | Deprecated |
Namespaces
Name | Description | |
---|---|---|
CategoryDescription | ||
DisplayValue | ||
DisplayValueGroup | ||
FieldDescriptor | ||
NestedContentValue | ||
Property | ||
SelectClassInfo | ||
Value |
Type Aliases
Name | Description | |
---|---|---|
DisplayValue | Display value type. | |
DisplayValueJSON | JSON representation of DisplayValue | Deprecated |
FieldDescriptor | A union of all possible field descriptor types | |
FieldJSON | JSON representation of a Field | |
PropertyAccessorPath | Describes path to a property. | |
TypeDescription | One of content field type descriptions. | |
Value | Raw value type | |
ValueJSON | JSON representation of Value | Deprecated |
Last Updated: 30 November, 2023