SaveRenderingStyleTool Class
Beta
Outputs (and optionally copies to the clipboard) a "rendering style" as a partial DisplayStyle3dSettingsProps JSON object based
on the current view's display style settings.
All arguments are optional, of the form "name=value" where value
is 0 for false or 1 for true. All arguments default to false
if omitted.
see DisplayStyleSettings.toOverrides for details. Arguments:
all
: include all settings.imodel
: include iModel-specific settings.project
: include iTwin-specific (formerly known as project) settings.map
: include background map settings.drawingaids
: include drawing aid decoration settings.copy
: copy result to system clipboard.quote
: format the JSON so it can be parsed directly by [ApplyRenderingStyleTool].
Extends
Methods
Name | Description | |
---|---|---|
constructor(..._args: any[]): SaveRenderingStyleTool | ||
execute(vp: Viewport): Promise<boolean> | ||
parse(inputArgs: string[]): Promise<boolean> |
Inherited methods
Name | Inherited from | Description |
---|---|---|
parseAndRun(...args: string[]): Promise<boolean> | DisplayStyleTool | |
run(): Promise<boolean> | DisplayStyleTool | |
register(namespace?: string): void Static | DisplayStyleTool | Register this Tool class with the ToolRegistry. |
Properties
Name | Type | Description | |
---|---|---|---|
maxArgs Accessor StaticReadOnly | number | ||
minArgs Accessor StaticReadOnly | number | ||
toolId Static | string | The unique string that identifies this tool. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
description Accessor ReadOnly | string | DisplayStyleTool | Get the localized description string from this Tool's class |
description Accessor StaticReadOnly | string | DisplayStyleTool | Get the localized description for this Tool class. This returns the value of "tools." + this.toolId + ".description" from its registered Namespace (e.g. "en/MyApp.json"). If that key is not in the localization namespace, DisplayStyleTool.flyover is returned. |
englishKeyin Accessor StaticReadOnly | string | DisplayStyleTool | Get the English keyin string for this Tool class. This returns the value of "tools." + this.toolId + ".keyin" from its registered Namespace (e.g. "en/MyApp.json"). |
flyover Accessor ReadOnly | string | DisplayStyleTool | Get the localized flyover string from this Tool's class |
flyover Accessor StaticReadOnly | string | DisplayStyleTool | Get the localized flyover for this Tool class. This returns the value of "tools." + this.toolId + ".flyover" from its registered Namespace (e.g. "en/MyApp.json"). If that key is not in the localization namespace, DisplayStyleTool.keyin is returned. |
hidden Static | boolean | DisplayStyleTool | If true, this Tool will not appear in the list from getToolList. |
iconSpec Accessor ReadOnly | string | DisplayStyleTool | Get the iconSpec from this Tool's class. |
iconSpec Static | string | DisplayStyleTool | The icon for this Tool. |
keyin Accessor ReadOnly | string | DisplayStyleTool | Get the localized keyin string from this Tool's class |
keyin Accessor StaticReadOnly | string | DisplayStyleTool | Get the localized keyin string for this Tool class. This returns the value of "tools." + this.toolId + ".keyin" from its registered Namespace (e.g. "en/MyApp.json"). |
namespace Static | string | DisplayStyleTool | The namespace that provides localized strings for this Tool. |
require3d Accessor ProtectedReadOnly | boolean | DisplayStyleTool | |
toolId Accessor ReadOnly | string | DisplayStyleTool | Get the toolId string for this Tool class. This string is used to identify the Tool in the ToolRegistry and is used to localize the keyin, description, etc. from the current locale. |
Defined in
Last Updated: 30 November, 2023