MapLayerVisibilityTool Class
Beta
This tool sets the visibility of the map layer.
Extends
Methods
Name | Description | |
---|---|---|
constructor(..._args: any[]): MapLayerVisibilityTool | ||
parseAndRun(...args: string[]): Promise<boolean> | Executes this tool's run method with args[0] containing enable and args[1] containing layerIndex . |
|
run(layerIndex: number, enable?: boolean): Promise<boolean> | This method runs the tool, setting the visibility of a map layer. |
Inherited methods
Name | Inherited from | Description |
---|---|---|
register(namespace?: string): void Static | Tool | Register this Tool class with the ToolRegistry. |
Properties
Name | Type | Description | |
---|---|---|---|
maxArgs Accessor StaticReadOnly | number | ||
minArgs Accessor StaticReadOnly | number | ||
toolId Static | string |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
description Accessor ReadOnly | string | Tool | Get the localized description string from this Tool's class |
description Accessor StaticReadOnly | string | Tool | Get the localized description for this Tool class. This returns the value of "tools." + this.toolId + ".description" from its registered Namespace (e.g. "en/MyApp.json"). If that key is not in the localization namespace, flyover is returned. |
englishKeyin Accessor StaticReadOnly | string | Tool | Get the English keyin string for this Tool class. This returns the value of "tools." + this.toolId + ".keyin" from its registered Namespace (e.g. "en/MyApp.json"). |
flyover Accessor ReadOnly | string | Tool | Get the localized flyover string from this Tool's class |
flyover Accessor StaticReadOnly | string | Tool | Get the localized flyover for this Tool class. This returns the value of "tools." + this.toolId + ".flyover" from its registered Namespace (e.g. "en/MyApp.json"). If that key is not in the localization namespace, keyin is returned. |
hidden Static | boolean | Tool | If true, this Tool will not appear in the list from getToolList. |
iconSpec Accessor ReadOnly | string | Tool | Get the iconSpec from this Tool's class. |
iconSpec Static | string | Tool | The icon for this Tool. |
keyin Accessor ReadOnly | string | Tool | Get the localized keyin string from this Tool's class |
keyin Accessor StaticReadOnly | string | Tool | Get the localized keyin string for this Tool class. This returns the value of "tools." + this.toolId + ".keyin" from its registered Namespace (e.g. "en/MyApp.json"). |
namespace Static | string | Tool | The namespace that provides localized strings for this Tool. |
toolId Accessor ReadOnly | string | Tool | Get the toolId string for this Tool class. This string is used to identify the Tool in the ToolRegistry and is used to localize the keyin, description, etc. from the current locale. |
Defined in
Last Updated: 30 November, 2023