FrustumDecorator Class
Beta
Decorates the viewport with a graphical depiction of a Frustum. This is obviously only useful when drawn inside a viewport using a different Frustum. Options for doing so include:
- Having more than one viewport, and drawing the frustum of one viewport inside the other viewports; and
- Allowing the user to take a snapshot of the current frustum, then navigate the view to inspect it within the same viewport.
Implements
Methods
Name | Description | |
---|---|---|
decorate(context: DecorateContext): void | ||
disable(): void Static | Remove the decoration from the specified viewport. | |
enable(vp: Viewport, options?: FrustumDecorationOptions): void Static | Add the decoration to the specified viewport. |
Properties
Defined in
Last Updated: 30 November, 2023