constructor Method
Initializes a new SchemaDiagnostic.
SchemaDiagnostic<ARGS extends any[]>(schema: Schema, messageArgs: ARGS, category: DiagnosticCategory = DiagnosticCategory.Error): SchemaDiagnostic<ARGS>
Parameter | Type | Description |
---|---|---|
schema | Schema | |
ARGS | The arguments used when formatting the diagnostic message. | |
category | DiagnosticCategory | The DiagnosticCategory to associate with the diagnostic, Error by default. |
Returns - SchemaDiagnostic<ARGS>
Defined in
Last Updated: 30 November, 2023