SchemaDiagnostic<ARGS extends any[]> Class
Beta
An IDiagnostic implementation used for SchemaDiagnostic.Schema diagnostics.
Extends
Methods
Properties
Name |
Type |
Description |
|
diagnosticType Accessor ReadOnly |
DiagnosticType |
Gets the DiagnosticType. |
|
diagnosticType Static |
DiagnosticType |
|
|
schema Accessor ReadOnly |
Schema |
Gets the schema where the diagnostic originated. |
|
Inherited properties
Name |
Type |
Inherited from |
Description |
category |
DiagnosticCategory |
BaseDiagnostic<Schema, ARGS> |
The diagnostic category is of the type DiagnosticCategory; which is defined as an enumeration above. |
code Accessor AbstractReadOnly |
string |
BaseDiagnostic<Schema, ARGS> |
Gets the unique string identifier for the diagnostic in the format ':'. |
ecDefinition |
Schema |
BaseDiagnostic<Schema, ARGS> |
The EC object to associate with the diagnostic. |
messageArgs |
undefined | ARGS |
BaseDiagnostic<Schema, ARGS> |
The arguments used when formatting the diagnostic message. |
messageText Accessor AbstractReadOnly |
string |
BaseDiagnostic<Schema, ARGS> |
Gets the message associated with the diagnostic. |
Defined in
Last Updated:
30 November, 2023