PropertyDiagnostic<ARGS extends any[]> Class
Beta
An IDiagnostic implementation used for PropertyDiagnostic.Property diagnostics.
Extends
- BaseDiagnostic<AnyProperty, ARGS>
Methods
Name | Description | |
---|---|---|
constructor<ARGS extends any[]>(property: AnyProperty, messageArgs?: ARGS, category: DiagnosticCategory = DiagnosticCategory.Error): PropertyDiagnostic<ARGS> | Initializes a new PropertyDiagnostic. |
Properties
Name | Type | Description | |
---|---|---|---|
diagnosticType Accessor ReadOnly | DiagnosticType | Gets the DiagnosticType. | |
schema Accessor ReadOnly | Schema | Gets the schema where the diagnostic originated. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
category | DiagnosticCategory | BaseDiagnostic<AnyProperty, ARGS> | The diagnostic category is of the type DiagnosticCategory; which is defined as an enumeration above. |
code Accessor AbstractReadOnly | string | BaseDiagnostic<AnyProperty, ARGS> | Gets the unique string identifier for the diagnostic in the format ' |
ecDefinition | AnyProperty | BaseDiagnostic<AnyProperty, ARGS> | The EC object to associate with the diagnostic. |
undefined | ARGS | BaseDiagnostic<AnyProperty, ARGS> | The arguments used when formatting the diagnostic message. | |
string | BaseDiagnostic<AnyProperty, ARGS> | Gets the message associated with the diagnostic. |
Defined in
Last Updated: 30 November, 2023