HalfEdgePointerInspector Class
HalfEdgePointerInspector has methods to check HalfEdge objects for pointer errors.
- For a one-step test of the whole graph,
Methods
Name | Description | |
---|---|---|
constructor(): HalfEdgePointerInspector | ||
clearCounts(): void | Clear all counts | |
inspectHalfEdge(he: ): void | Inspect a single half edge. | |
inspectHalfEdges(graph: ): void | inspect all half edges of graph. | |
inspectGraph(graph: , expectAllMates: boolean): boolean Static | Inspect a graph's pointer properties. |
Properties
Name | Type | Description | |
---|---|---|---|
isValidClosedHalfEdgeGraph Accessor ReadOnly | boolean | Return true if all pointer pairings are correct for a complete half edge graph: | |
isValidHalfEdgeGraphAllowRaggedBoundary Accessor ReadOnly | boolean | Return true if all counts are correct for a half edge graph that has complete pairings: | |
numFSFPError | number | ||
numMatePairError | number | ||
numTested | number | ||
numUndefinedEdgeMate | number | ||
numUndefinedFP | number | ||
numUndefinedFS | number | ||
numWithMatchedEdgeMate | number |
Defined in
Last Updated: 30 November, 2023