fillSimpleHoles MethodStatic
Return a mesh with "some" holes filled in with new facets.
- The candidates to be filled are all loops returned by boundaryChainsAsLineString3d
- unclosed chains are rejected.
- optionally also copy the original mesh, so the composite is a clone with holes filled.
- The options structure enforces restrictions on how complicated the hole filling can be:
- maxEdgesAroundHole -- holes with more edges are skipped
- maxPerimeter -- holes with larger summed edge lengths are skipped.
- upVector -- holes that do not have positive area along this view are skipped.
- includeOriginalMesh -- includes the original mesh in the output mesh.
fillSimpleHoles(mesh: Polyface | PolyfaceVisitor, options: HoleFillOptions, unfilledChains?: LineString3d[]): undefined | IndexedPolyface
Parameter | Type | Description |
---|---|---|
mesh | Polyface | PolyfaceVisitor | existing mesh |
options | HoleFillOptions | options controlling the hole fill. |
unfilledChains | LineString3d[] | optional array to receive the points around holes that were not filled. |
Returns - undefined | IndexedPolyface
Defined in
- polyface/PolyfaceQuery.ts Line 697
Last Updated: 30 November, 2023