HoleFillOptions Interface
Options carrier for cloneWithHolesFilled
Properties
Name | Type | Description | |
---|---|---|---|
includeOriginalMesh | undefined | boolean | requests that all content from the original mesh be copied to the mesh with filled holes. | |
maxEdgesAroundHole | undefined | number | REJECT hole candidates if they have more than this number of edges | |
maxPerimeter | undefined | number | REJECT hole candidates if its boundary chain is longer than this limit. | |
upVector | undefined | Vector3d | REJECT hole candidates if their orientation is not COUNTERCLOCKWISE around this vector. |
Defined in
- polyface/PolyfaceQuery.ts Line 51
Last Updated: 30 November, 2023