FacetIntersectOptions Class
Options for computing and processing facet intersection methods.
see PolyfaceQuery.intersectRay3d
Methods
Name | Description | |
---|---|---|
constructor(): FacetIntersectOptions | constructor with defaults |
Properties
Name | Type | Description | |
---|---|---|---|
acceptIntersection | undefined | FacetIntersectCallback | optional callback to accept an intersected facet | |
distanceTolerance | number | distance tolerance for testing coincidence with facet boundary | |
needBarycentricCoordinates | undefined | boolean | whether to compute the barycentric coordinates of the point for a convex facet | |
needColor | undefined | boolean | whether to compute the color at the intersection point | |
needNormal | undefined | boolean | whether to compute the normal at the intersection point | |
needParam | undefined | boolean | whether to compute the uv parameter at the intersection point | |
parameterTolerance | number | fractional tolerance for snapping barycentric coordinates to a triangular facet edge |
Defined in
- polyface/FacetLocationDetail.ts Line 31
Last Updated: 30 November, 2023