CurveExtendOptions Class
Logic for deciding how a curve may be extended for closest point or intersection searches.
Methods
Name | Description | |
---|---|---|
constructor(): CurveExtendOptions | ||
correctFraction(extendParam: VariantCurveExtendParameter, fraction: number): number Static | * if fraction is between 0 and 1 return it unchanged. | |
resolveRadiansToSweepFraction(extendParam: VariantCurveExtendParameter, radians: number, sweep: AngleSweep): number Static | Adjust a radians value to an angle sweep, allowing the extendParam to affect choice among periodic fractions. | |
resolveVariantCurveExtendParameterToCurveExtendMode(param: VariantCurveExtendParameter, endIndex: | "1"): CurveExtendMode Static | Given an ExtendParameter, isolate the particular CurveExtendOptions in effect at an end. |
Defined in
- curve/CurveExtendMode.ts Line 28
Last Updated: 30 November, 2023