intersectRay3d MethodStatic
Compute the intersection of a line (parameterized as a ray) with the plane of this polygon.
intersectRay3d(polygon: Point3d[] | IndexedXYZCollection, ray: Ray3d, tolerance: number = Geometry.smallMetricDistance, result?: PolygonLocationDetail): PolygonLocationDetail
Parameter | Type | Description |
---|---|---|
polygon | Point3d[] | IndexedXYZCollection | points of the polygon, closure point optional |
ray | Ray3d | infinite line to intersect, as a ray |
tolerance | number | optional distance tolerance to determine point-vertex and point-edge coincidence. |
result | PolygonLocationDetail | optional pre-allocated object to fill and return |
Returns - PolygonLocationDetail
details d of the line-plane intersection d.point
:
d.isValid()
returns true if and only if the line intersects the plane.d.code
indicates where the intersection lies with respect to the polygon.d.a
is the ray intersection parameter. Ifd.a
>= 0, the ray intersects the plane of the polygon.d.edgeIndex
andd.edgeParam
specify the location of the closest point on the polygon to the intersection, withindistTol
.
Defined in
- geometry3d/PolygonOps.ts Line 1018
Last Updated: 30 November, 2023