PolygonLocationDetail Class
Carries data about a point in the plane of a polygon.
Methods
Name | Description | |
---|---|---|
copyContentsFrom(other: PolygonLocationDetail): void | Set the instance contents from the other detail. | |
invalidate(): void | Invalidate this detail. | |
create(result?: PolygonLocationDetail): PolygonLocationDetail Static | Create an invalid detail. |
Properties
Name | Type | Description | |
---|---|---|---|
a | number | Application-specific number | |
closestEdgeIndex | number | Index of the polygon vertex at the base of the edge closest to p. | |
closestEdgeParam | number | The parameter along the closest edge of the projection of p. | |
code | PolygonLocation | A number that classifies the point's location with respect to the polygon. | |
isInsideOrOn Accessor ReadOnly | boolean | Whether this instance specifies a location inside or on the polygon. | |
isValid Accessor ReadOnly | boolean | Whether this detail is valid. | |
point | Point3d | The coordinates of the point p. | |
v | Vector3d | Application-specific vector |
Defined in
- geometry3d/PolygonOps.ts Line 31
Last Updated: 30 November, 2023