pointToFraction Method
Compute the projection of the given point onto the plane of this triangle.
pointToFraction(point: Point3d, result?: TriangleLocationDetail): TriangleLocationDetail
see BarycentricTriangle.fractionToPoint
Parameter | Type | Description |
---|---|---|
point | Point3d | point p to project |
result | TriangleLocationDetail | optional pre-allocated object to fill and return |
Returns - TriangleLocationDetail
details d of the projection point P = d.point
:
d.isValid
returns true if and only ifthis.normal()
is defined.d.classify
can be used to determine where P lies with respect to the triangle.d.a
is the signed projection distance: P = p + a *this.normal()
.
Defined in
- geometry3d/BarycentricTriangle.ts Line 203
Last Updated: 30 November, 2023