fractionToPoint Method
Sum the points with given scales.
- If the scales sum to 1, they are barycentric coordinates, and hence the result point is in the plane of the triangle.
- If the scales do not sum to 1, the point is in the triangle scaled (by the scale sum) from the origin.
fractionToPoint(b0: number, b1: number, b2: number, result?: Point3d): Point3d
see BarycentricTriangle.pointToFraction
Parameter | Type | Description |
---|---|---|
b0 | number | scale to apply to vertex 0 |
b1 | number | scale to apply to vertex 1 |
b2 | number | scale to apply to vertex 2 |
result | Point3d | optional pre-allocated point to fill and return |
Returns - Point3d
linear combination of the vertices of this triangle
Defined in
- geometry3d/BarycentricTriangle.ts Line 184
Last Updated: 30 November, 2023