connect Method
Establish the connection between two Viewports. When this method is called, viewport2
is initialized with the state of viewport1
via connectViewports.
Thereafter, any change to the frustum of either viewport will be reflected in the frustum of the other viewport via TwoWayViewportSync.syncViewports.
connect(viewport1: Viewport, viewport2: Viewport): void
Parameter | Type | Description |
---|---|---|
viewport1 | Viewport | |
viewport2 | Viewport |
Returns - void
Defined in
- core/frontend/src/ViewportSync.ts Line 170
Last Updated: 30 November, 2023