syncViewports MethodProtected
Invoked each time source
changes to update target
to match.
The default implementation applies a clone of source
's ViewState to target
.
syncViewports(source: Viewport, target: Viewport): void
see connectViewports to set up the initial synchronization between the two viewports.
Parameter | Type | Description |
---|---|---|
source | Viewport | The viewport that changed |
target | Viewport | The viewport that should be updated to match source |
Returns - void
Defined in
- core/frontend/src/ViewportSync.ts Line 163
Last Updated: 30 November, 2023