RpcInterface
Types for working with RpcInterfaces.
Classes
Name | Description | |
---|---|---|
BentleyCloudRpcConfiguration | Operating parameters for Bentley cloud RPC interface deployments. | Beta |
BentleyCloudRpcManager | Coordinates usage of RPC interfaces for Bentley cloud deployments. | Beta |
IModelNotFoundResponse | Response if the IModelDb was not found at the backend | |
IModelTileRpcInterface | ||
RpcConfiguration | A RpcConfiguration specifies how calls on an RPC interface will be marshalled, plus other operating parameters. | Beta |
RpcControlResponse | An RPC operation control response. | |
RpcInterface | An RPC interface is a set of operations exposed by a service that a client can call, using configurable protocols, | |
RpcManager | RPC interface management is concerned with coordination of access and configuration for RPC interfaces. | Beta |
RpcNotFoundResponse | A RPC operation response. | |
RpcPendingResponse | A pending RPC operation response. | |
RpcRoutingToken | Beta |
Enumerations
Name | Description | |
---|---|---|
RpcContentType | RPC content types. | Deprecated |
RpcEndpoint | Endpoints for RPC protocols. | Deprecated |
RpcProtocolEvent | RPC protocol event types. | Deprecated |
RpcRequestEvent | RPC request event types. | Deprecated |
RpcRequestStatus | The status of an RPC operation request. | Deprecated |
RpcResponseCacheControl | Describes available options for RPC response caching. |
Interfaces
Name | Description | |
---|---|---|
BentleyCloudRpcParams | Initialization parameters for BentleyCloudRpcConfiguration. | Beta |
HttpServerRequest | An HTTP server request object. | Deprecated |
HttpServerResponse | An HTTP server response object. | Deprecated |
ModelExtentsProps | Describes the volume of geometry contained with a GeometricModel as returned by | |
OpenAPIInfo | An OpenAPI 3.0 info object. | Deprecated |
RpcActivity | The properties of an RpcActivity. | |
RpcInterfaceDefinition | Specifies the required static properties of an RpcInterface class. | Beta |
RpcInterfaceEndpoints | Describes the endpoints of an RPC interface. | Beta |
SerializedRpcActivity | Serialized format for sending the request across the RPC layer | |
SessionProps | Properties that identify a session. |
Namespaces
Name | Description | |
---|---|---|
RpcRequestStatus |
Type Aliases
Name | Description | |
---|---|---|
RpcInterfaceImplementation |
Last Updated: 30 November, 2023