CloudStorageCache<TContentId, TContentType> Class
Deprecated in 3.x. Use TileStorage (frontend) and TileStorage (backend) instead.
Beta
Extended by
Methods
Name | Description | |
---|---|---|
constructor<TContentId, TContentType>(): CloudStorageCache<TContentId, TContentType> | ||
formContainerKey(id: TContentId): string Protected | ||
formContainerName(id: TContentId): string Abstract | ||
formResourceName(id: TContentId): string Abstract | ||
getContainer(id: TContentId): Promise<CloudStorageContainerUrl> Protected | ||
instantiateResource(response: Response): Promise<undefined | TContentType> ProtectedAbstract | ||
obtainContainerUrl(id: TContentId, descriptor: CloudStorageContainerDescriptor): Promise<CloudStorageContainerUrl> ProtectedAbstract | ||
requestResource(container: CloudStorageContainerUrl, id: TContentId): Promise<Response> Protected | ||
retrieve(id: TContentId): Promise<undefined | TContentType> | ||
supplyUrlBase(_container: CloudStorageContainerUrl, _id: TContentId): undefined | string Protected |
Properties
Name | Type | Description | |
---|---|---|---|
provider | CloudStorageProvider |
Defined in
- core/common/src/CloudStorage.ts Line 68
Last Updated: 30 November, 2023