Workspace
APIs for loading and using Settings and Workspace resources
Classes
Name | Description | |
---|---|---|
SettingsSchemas | The registry of available SettingSchemaGroups. | Beta |
Constants
Name | Description | |
---|---|---|
WorkspaceSetting | The Settings used by Workspace api | Beta |
Enumerations
Name | Description | |
---|---|---|
SettingsPriority | Values for SettingsPriority determine the sort order for Settings. | Beta |
Interfaces
Name | Description | |
---|---|---|
SettingInspector | An entry in the array returned by Settings.inspectSetting | Beta |
SettingObject | An object with string-named members (as opposed to an array object). | Beta |
Settings | The current set of Settings for a Workspace. | Beta |
SettingSchema | The properties of a single Setting, used by the settings editor. | Beta |
SettingSchemaGroup | The properties of a group of SettingSchemas for an application. | Beta |
Workspace | Settings and resources that customize an application for the current session. | Beta |
WorkspaceCloudCacheProps | The properties of the CloudCache used for Workspaces. | Beta |
WorkspaceContainer | A WorkspaceContainer holds WorkspaceDbs. | Beta |
WorkspaceDb | A WorkspaceDb holds workspace resources. | Beta |
WorkspaceOpts | Options for constructing a Workspace. | Beta |
Namespaces
Name | Description | |
---|---|---|
WorkspaceAccount | Types used to identify cloud accounts for Workspaces. | Beta |
WorkspaceContainer | Beta | |
WorkspaceDb | Beta | |
WorkspaceResource | Types used to identify Workspace resources | Beta |
Type Aliases
Name | Description | |
---|---|---|
DictionaryName | The name of a SettingDictionary. | Beta |
SettingDictionary | An object with Settings as its members. | Beta |
SettingName | The name of a Setting. | Beta |
SettingResolver | ||
SettingType | The type of a Setting, according to its schema | Beta |
Last Updated: 30 November, 2023