LineStyleDefinition.StrokePatternProps Interface
Stroke pattern component definition LineStyleDefinition.ComponentType.StrokePattern. A stroke pattern component consists of a series of dashes and gaps having specified lengths and widths in meters. Simple dash-dot type line styles that do not include point symbols can be created by referencing a stroke pattern component by its file property id.
Properties
Name | Type | Description | |
---|---|---|---|
descr | string | Name for this stroke pattern | |
maxIter | undefined | number | The entire stroke pattern will be repeated no more than maxIter on curve or segment when LineStyleDefinition.StrokePatternOptions.Iteration is set and stroke pattern includes stretchable strokes. | |
options | undefined | LineStyleDefinition.StrokePatternOptions | Options mask for this stroke pattern | |
phase | undefined | number | Skip into the pattern before starting to draw. | |
strokes | LineStyleDefinition.Strokes | Array of strokes, maximum number that will be used is 32 |
Defined in
- backend/src/LineStyle.ts Line 126
Last Updated: 30 November, 2023