LineStyleDefinition.StrokePatternOptions Enumeration
Options to control how stroke pattern is applied to underlying curve
Members
Name | Value | Description |
---|---|---|
None | 0 | Use default stroke behavior |
AutoPhase | 1 | LineStyleDefinition.StrokePatternProps.phase represents fractional distance into first stroke of pattern |
Iteration | 8 | Use LineStyleDefinition.StrokePatternProps.maxIter to limit the number of iterations of the stroke pattern |
Segment | 16 | Single segment mode restarts the stroke pattern at corners instead of continuing around corners |
CenterStretch | 32 | Center the line style and stretch the ends |
Defined in
- backend/src/LineStyle.ts Line 109
Last Updated: 30 November, 2023