PhysicalElementIsOfType Class
Relates a PhysicalElement to its PhysicalType
Extends
Methods
Name | Description | |
---|---|---|
constructor(id: string, relClassName: string = PhysicalElementIsOfType.classFullName): PhysicalElementIsOfType |
Inherited methods
Name | Inherited from | Description |
---|---|---|
toJSON(): RelatedElementProps | GeometricElement3dHasTypeDefinition | |
fromJSON(json?: RelatedElementProps): undefined | RelatedElement Static | GeometricElement3dHasTypeDefinition | |
idFromJson(json: any): string Static | GeometricElement3dHasTypeDefinition | Accept the value of a navigation property that might be in the shortened format of just an id or might be in the full RelatedElement format. |
Properties
Name | Type | Description | |
---|---|---|---|
classFullName Static | string |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
id Readonly | string | GeometricElement3dHasTypeDefinition | The Id of the element to which this element is related. |
none StaticReadonly | RelatedElement | GeometricElement3dHasTypeDefinition | Used to null out an existing navigation relationship. |
relClassName Readonly | undefined | string | GeometricElement3dHasTypeDefinition | The full className of the relationship class. |
Defined in
Last Updated: 30 November, 2023