ElementTreeWalkerScope Class
Beta
Records the path that a tree search took to reach an element or model. This object is immutable.
Methods
Name | Description | |
---|---|---|
constructor(topElement: string, model: Model): ElementTreeWalkerScope | ||
constructor(enclosingScope: ElementTreeWalkerScope, newScope: string | Model): ElementTreeWalkerScope | ||
toString(): string | ||
createTopScope(iModel: IModelDb, topElementId: string): ElementTreeWalkerScope Static |
Properties
Name | Type | Description | |
---|---|---|---|
enclosingModel Accessor ReadOnly | Model | ||
enclosingModelInfo Readonly | ElementTreeWalkerModelInfo | cached info about the immediately enclosing model (i.e., the last model in path) | |
inDefinitionModel Accessor ReadOnly | boolean | ||
inRepositoryModel Accessor ReadOnly | boolean | ||
path Readonly | string | ElementTreeWalkerModelInfo[] | path of parent elements and enclosing models | |
topElement Readonly | string |
Defined in
- backend/src/ElementTreeWalker.ts Line 62
Last Updated: 30 November, 2023