WidgetManager Class
Beta
Widget Manager class.
Methods
Name | Description | |
---|---|---|
constructor(): WidgetManager | ||
addWidgetDef(widgetDef: WidgetDef, stageId: undefined | string, stageUsage: undefined | string, location: ZoneLocation | StagePanelLocation, section?: StagePanelSection): boolean | Adds a WidgetDef for use in a Frontstage. | |
getWidgetDefs(stageId: string, stageUsage: string, location: ZoneLocation | StagePanelLocation, section?: StagePanelSection, frontstageApplicationData?: any): undefined | | Gets WidgetDefs for a Frontstage location. | |
removeWidgetDef(widgetId: string): boolean | Removes a WidgetDef. |
Defined in
Last Updated: 30 November, 2023