CursorPopupManager Class
CursorPopup component
Methods
Name | Description | |
---|---|---|
constructor(): CursorPopupManager | ||
close(id: string, apply: boolean, fadeOut?: boolean): void Static | Called when tool wants to close the popup | |
open(id: string, content: ReactNode, pt: PointProps, offset: PointProps, relativePosition: RelativePosition, priority: number = 0, options?: CursorPopupOptions): void Static | Called to open popup with a new set of properties | |
update(id: string, content: ReactNode, pt: PointProps, offset: PointProps, relativePosition: RelativePosition, priority: number = 0): void Static | Called to update popup with a new set of properties | |
updatePosition(pt: PointProps): void Static | Called to move the open popup to new location |
Properties
Name | Type | Description | |
---|---|---|---|
popupCount Accessor StaticReadOnly | number | ||
popups Accessor StaticReadOnly | CursorPopupInfo[] |
Defined in
Last Updated: 30 November, 2023