CursorInformation Class
Cursor Information class
Methods
Name | Description | |
---|---|---|
constructor(): CursorInformation | ||
getRelativePositionFromCursorDirection(cursorDirection: CursorDirection): RelativePosition Static | Gets the relative position based on the cursor direction. | |
handleMouseMove(point: PointProps): void Static | Handles the mouse movement. |
Properties
Name | Type | Description | |
---|---|---|---|
cursorDirection Accessor StaticReadOnly | CursorDirection | Gets the general cursor movement direction. | |
cursorPosition Accessor Static | PointProps | The cursor position. | |
cursorX Accessor StaticReadOnly | number | Gets the cursor X position. | |
cursorY Accessor StaticReadOnly | number | Gets the cursor Y position. | |
onCursorUpdatedEvent StaticReadonly | CursorUpdatedEvent | Gets the CursorUpdatedEvent. |
Defined in
Last Updated: 30 November, 2023