presentation-components
Classes
Name | Description | |
---|---|---|
ContentDataProvider | Base class for all presentation-driven content providers. | |
DataProvidersFactory | A factory class than can be used to create presentation data providers targeted towards | |
FavoritePropertiesDataProvider | Presentation Rules-driven element favorite properties data provider implementation. | Beta |
LabelsProvider | Presentation Rules-driven labels provider implementation. | |
PresentationPropertyDataProvider | Presentation Rules-driven property data provider implementation. | |
PresentationTableDataProvider | Presentation Rules-driven table data provider. | |
PresentationTreeDataProvider | Presentation Rules-driven tree data provider. | |
UnifiedSelectionTreeEventHandler | Tree event handler that handles unified selection. | Beta |
Constants
Name | Description | |
---|---|---|
TABLE_DATA_PROVIDER_DEFAULT_CACHED_PAGES_COUNT | The default number of pages cached by PresentationTableDataProvider | |
TABLE_DATA_PROVIDER_DEFAULT_PAGE_SIZE | The default number of rows in a single page requested by PresentationTableDataProvider |
Global Functions
Name | Description | |
---|---|---|
controlledTreeWithFilteringSupport | A HOC component that adds filtering functionality to the supplied | Beta |
controlledTreeWithVisibleNodes | A HOC component that injects visible nodes into supplied tree component. | Beta |
propertyGridWithUnifiedSelection | A HOC component that adds unified selection functionality to the supplied | |
tableWithUnifiedSelection | A HOC component that adds unified selection functionality to the supplied | |
treeWithFilteringSupport | A HOC component that adds filtering functionality to the supplied | |
treeWithUnifiedSelection | A HOC component that adds unified selection functionality to the supplied | |
useControlledTreeFiltering | A custom hook that creates filtered model source and node loader for supplied filter. | Beta |
usePresentationNodeLoader | Custom hooks which creates PagedTreeNodeLoader with PresentationTreeDataProvider using | Beta |
useUnifiedSelectionEventHandler | Hooks which creates and disposes UnifiedSelectionTreeEventHandler | Beta |
viewWithUnifiedSelection | A HOC component that adds unified selection functionality to the supplied |
Interfaces
Name | Description | |
---|---|---|
ControlledTreeWithFilteringSupportProps | Props that are injected to the ControlledTreeWithFilteringSupport HOC component. | Beta |
ControlledTreeWithVisibleNodesProps | Props that are injected to the ControlledTreeWithModelSource HOC component. | Beta |
DataProvidersFactoryProps | Data structure holding initialization properties for DataProvidersFactory | |
FavoritePropertiesDataProviderProps | Beta | |
IContentDataProvider | Interface for all presentation-driven content providers. | |
IPresentationDataProvider | Interface for a presentation data provider | |
IPresentationLabelsProvider | Interface for presentation rules-driven labels provider. | |
IPresentationTreeDataProvider | Presentation tree data provider. | |
IUnifiedSelectionComponent | An interface for all unified selection components | |
PresentationNodeLoaderProps | Properties for usePresentationNodeLoader hook. | Beta |
PresentationTableDataProviderProps | Initialization properties for PresentationTableDataProvider | |
PropertyGridWithUnifiedSelectionProps | Props that are injected to the PropertyGridWithUnifiedSelection HOC component. | |
TableWithUnifiedSelectionProps | Props that are injected to the TableWithUnifiedSelection HOC component. | |
TreeWithFilteringSupportProps | Props that are injected to the TreeWithFilteringSupport HOC component. | |
TreeWithUnifiedSelectionProps | Props that are injected to the TreeWithUnifiedSelection HOC component. | |
UnifiedSelectionTreeEventHandlerParams | Data structure that describes parameters for UnifiedSelectionTreeEventHandler | Beta |
ViewWithUnifiedSelectionProps | Props that are injected to the ViewWithUnifiedSelection HOC component. |
Namespaces
Name | Description | |
---|---|---|
CacheInvalidationProps |
Type Aliases
Name | Description | |
---|---|---|
IPresentationPropertyDataProvider | Interface for presentation rules-driven property data provider. | |
IPresentationTableDataProvider | Interface for presentation rules-driven table data provider. |
Last Updated: 13 June, 2024